Telemetry Update: New job_type Field and Naming Fix

We've added a new job_type field to the kbc_job table, allowing you to better identify container jobs, such as those from the orchestrator component, for when you are analyzing the runtime of your flows.

Unfortunately, there's a small issue: the new field was uploaded with an UPPERCASE name. To standardize naming, we'll rename the field to lowercase on Thursday, November 30. Since the Telemetry Data extractor saves data to storage in your project, this name change will cause errors during data extraction, as the field name from the extractor won't match the field name in storage.

The fix is simple. After the update (or when the mismatch error appears during extraction), just delete the JOB_TYPE column in the kbc_job storage table. The correctly named field will appear in the data after the next extractor run.

We sincerely apologize for this issue, but believe that maintaining clean naming conventions is worth this change. If you have any questions, please don't hesitate to contact our support team.